Installing Java on a Mac for PACER/ECF Access

The court document filing system ECF requires Java 1.6 to be installed. This is not the latest version of Java, because apparently there is a bug that prevents the latest Java from working with the system.

To install Java on a Mac running any new version of OS X, you will need to do the following:

  1. Install the latest OS X Java update (the 2014-001 update is here). You will note from the release notes that this will uninstall the web plugin (intended to make room for installation of the newer Java version).
  2. Follow the directions on this page, to reenable the plugin. Briefly, you will need to run four commands from a terminal:
sudo mkdir -p /Library/Internet\ Plug-Ins/disabled
sudo mv /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin /Library/Internet\ Plug-Ins/disabled
sudo ln -sf /System/Library/Java/Support/Deploy.bundle/Contents/Resources/JavaPlugin2_NPAPI.plugin /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin
sudo ln -sf /System/Library/Frameworks/JavaVM.framework/Commands/javaws /usr/bin/javaws

You can test the Java installation here.